Introduction

This document describes the SNMP Interface provided with InduSoft Web Studio (IWS) and CEView.

Simple Network Management Protocol (SNMP) is a popular protocol for network management. It is used for collecting information from, and configuring, network devices, such as servers, printers, hubs, switches, and routers on an Internet Protocol (IP) network.

In a typical SNMP architecture, there is one SNMP Manager station which Status Information from Devices Running SNMP Agent.

Using IWS or CEView, you can provide real-time data from the devices connected to the SCADA/HMI system through the native communication drivers (or OPC interface) – controllers, machines, and so forth – to a third-party SNMP Manager, such as HP Openview, Novell NMS, IBM NetView, or Sun Net Manager. In other words, IWS can work as a gateway between the devices in the plant-floor and the corporate equipment management system (SNMP Manager) in the ERP.

Furthermore, IWS can also request data from third-party SNMP Agents and display this information through its graphical interface, locally or remotely on the Thin Client stations.
Installation

The SNMP interface from IWS uses the standard SNMP Service from Microsoft. The installation procedure depends on the operating system where you install the system and some dialogs illustrated in this document may vary depending on the OS version/type that you are using.

- Installation on Microsoft Windows 2000, Windows XP or Windows 2003 Server

  - Install the Microsoft SNMP Service:

    Open the Control Panel (<Start> → Control Panel) and double-click on the Add/Remote Programs icon. Select the option Add/Remove Windows Components, click on the Management and Monitoring Tools option and then click on the button Details. Check the option Simple Network Management Protocol, then click on Ok and Next to install the Microsoft SNMP Service (in case it had not been installed before). You might need the operating system CD-ROM to install this service.

  - Configure the Microsoft SNMP Service:

    After installing the Microsoft SNMP Service, you must configure its settings. Open the Control Panel (<Start> → Control Panel), double-click on the Administrative Tools icon and finally double-click on the Services icon. Right-click on the SNMP Service name and click on Properties.

    Make sure that the Local System Account selected in the Log On tab.
Select the **Traps** tab and add the community name called **public** (in case it does not exist yet) and add to the **Trap destinations** box the host name or IP address of the station(s) that must receive traps from the SNMP Agent. In other words, the host name or IP address of the station(s) where the SNMP Manager is running.

**Note:** The SNMP protocol supports “unsolicited messages” (traps) from the SNMP Agent to the SNMP Manager (e.g.: change os status, alarm condition, etc) in order to optimize the communication in the network.
Select the **Security** tab and either select the option **Accept SNMP packets from any host** or select and option **Accept SNMP packets from these hosts** and add the list of host(s) where the SNMP Manager is running.
Configure the Studio SNMP Agent:

Open the Registry Editor (<Start> → Run → RegEdit). Select the key `HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SNMP\Parameters\ExtensionAgents`. This key lists the SNMP Agents linked to the Microsoft SNMP Service. Add a new String Value with the next sequential number available for the list and set its data value to `SOFTWARE\Studio\SNMP`.

Then create the Key `HKEY_LOCAL_MACHINE\SOFTWARE\Studio\SNMP` and add a new String value with the name `Pathname`, whose value must be set with the path of the Studio SNMP Agent DLL file (`StudioSnmp.dll`) – for example: `c:\Program Files\InduSoft Web Studio v6.1\bin\StudioSnmp.dll`. Close the Registry Editor.
Open the `Program Settings.INI` file with a text editor (e.g.: Notepad). The `Program Settings.INI` file is located on the `\BIN` sub-folder of the InduSoft Web Studio installation path (e.g.: `c:\Program Files\InduSoft Web Studio v6.1\bin\Program Settings.ini`). Create the following settings in the `Program Settings.INI` file:

```
[SNMP]
OidEnterpriseNumber=26640
TrapInterval=1
ApplicationTcpPort=1234
```

Save the changes and close the file editor.

**Notes:**
- `OidEnterpriseNumber`: Unique number, which defines the position in the SNMP tree where the Studio data will be exposed (.1.3.6.1.4.1.[OidEnterpriseNumber]). The Studio number is 26640.
- `TrapInterval`: Interval (in seconds) used to send traps to the remote SNMP Manager(s). This parameter must be configured with a integer positive number. The default value is 1.
- `ApplicationTcpPort`: TCP Port number used to exchange data with the TCP/IP Server task from InduSoft Web Studio. The default value is 1234.

After configuring all settings, re-start the SNMP Service by rebooting the computer or by right-clicking on the SNMP Service ( `<Start>` → Control Panel → Administrative Tools → Service ) and clicking on the option `Restart`.

**Importat:** The Studio SNMP Agent exchanges data with the TCP/IP Server task from InduSoft Web Studio. Therefore, the TCP/IP Server task MUST be running in order to provide data to the SNMP Agent module. Make sure to set the TCP/IP Server task `Automatic` in the InduSoft Web Studio menu Project → Status.

- **Installation on Microsoft Windows CE**
  - Install the Microsoft SNMP Service:
The SNMP Server must be previously enabled in the image of the Windows CE device. If your Windows CE device does not provide the SNMP Agent, please consult your hardware vendor and ask them to add this service to the image of the device.

- **Configure the Studio SNMP Agent:**

Copy the following files into a non-volatile directory of the Windows CE device (preferentially, the same directory where CEView.exe is installed):

- StudioSnmp.dll
- StudioSnmpReg.exe

**Note:** The files mentioned above are stored in the following sub-folder after installing InduSoft Web Studio in your computer: `\Redist\<OS_Version>\<ProcessorType>` (e.g.: `C:\Program Files\InduSoft Web Studio v6.1\Redist\Wince 4.0\x86`). You can use the **Send Files** command from the **Execution Environment** dialog of InduSoft Web Studio to download these files to your Windows CE device.

Optionally, you can create a text file with a Text Editor (e.g.: Notepad) and save it with the name **StudioSnmpReg.ini**. This file must follow the structure illustrated in the example below:

```plaintext
[SNMP]
SnmpAgentPath=<Full path to the file StudioSnmp.dll>
ProductPath=<Full path of the Bin folder of Studio>
OidEnterpriseNumber=<enterprise number>
ApplicationTcpPort=<TCP port used to communicate to Studio>
TrapInterval=<Trap period, in seconds>
SNMPDriverOrder=<SNMP driver order>

[Trap Destination]
1=<IP address>
2=<IP address>
3=<IP address>
```

The **StudioSnmpReg.ini** file allows you to customize some settings before installing the Studio SNMP Agent on your Windows CE device. If this file does not exist, the Studio SNMP Agent is installed with the default settings as described in the following table:

<table>
<thead>
<tr>
<th>Key</th>
<th>Default Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SnmpAgentPath</td>
<td>Same directory where the StudioSnmpReg.exe is executed from.</td>
<td>Path where the StudioSnmp.dll is stored.</td>
</tr>
<tr>
<td>ProductPath</td>
<td>Same directory where the StudioSnmpReg.exe is executed from.</td>
<td>Path for the \BIN sub-folder of CEView (same folder where CEView.exe is stored)</td>
</tr>
<tr>
<td>OidEnterpriseNumber</td>
<td>26640</td>
<td>Unique number, which defines the position in the SNMP tree where the Studio data will be exposed (.1.3.6.1.4.1.[OidEnterpriseNumber]).</td>
</tr>
<tr>
<td>TrapInterval</td>
<td>1</td>
<td>Interval (in seconds) used to send traps to the remote SNMP Manager(s). This parameter must be configured with an integer positive number.</td>
</tr>
<tr>
<td>ApplicationTcpPort</td>
<td>1234</td>
<td>TCP Port number used to exchange data with the TCP/IP Server task from InduSoft Web Studio.</td>
</tr>
</tbody>
</table>
In addition to the parameters mentioned above, the Key [Trap Destination] list the Host Name or IP Address of the station(s) that must receive traps from the SNMP Agent. In other words, the host name or IP address of the station(s) where the SNMP Manager is running.

Copy the StudioSnmpReg.ini (if any) to the same directory where the StudioSnmpReg.exe is stored (on the Windows CE device) and execute the StudioSnmpReg.exe program to install the Studio SNMP Agent on the Windows CE device. Wait until a message is displayed indicating the completion of the installation.

**Save the Registry** and reboot the Windows CE device and the Studio SNMP Agent must be automatically loaded by the SNMP Service from the operating system.

| SNMPDriverOrder | - | Order to load the SNMP Driver. Usually, this parameter is not required. Consult your software vendor if you have problems during the installation of the Studio SNMP Agent. |

**Note:** It is strongly recommended copying the StudioSnmpReg.ini, StudioSnmpReg.exe and StudioSnmp.dll in the same directory where CEView.exe is stored (e.g.: \HardDisk\Studio\BIN\).

**Important:** The Studio SNMP Agent exchanges data with the TCP/IP Server task from CEView. Therefore, the TCP/IP Server task MUST be running in order to provide data to the SNMP Agent module. Make sure to set the TCP/IP Server task **Automatic** in the InduSoft Web Studio menu Project → Status.
Studio SNMP Agent Settings

The Studio SNMP Agent exposes data from the current application via the SNMP protocol. The Studio SNMP Agent has a unique ID number. Each data value exposed by the Studio SNMP Agent has an address (OID). The root of the OID space is .1.3.6.1.4.1.[EN] or (iso.org.dod.internet.private.enterprise.[EN]), where [EN] is the number configured in the parameter OidEnterpriseNumber of the file Program Settings.INI (Windows 2K/XP/2K3) or StudioSnmpReg.ini (Windows CE). By default, the EN number is 26640.

The OIDs exposed by Studio SNMP Agent are listed below:

<table>
<thead>
<tr>
<th>Name</th>
<th>OID</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>studioVersion</td>
<td>1.3.6.1.4.1.[EN].1.1.0</td>
<td>String</td>
<td>Studio version number</td>
</tr>
<tr>
<td>studioLicence</td>
<td>1.3.6.1.4.1.[EN].1.2.0</td>
<td>String</td>
<td>Studio license type</td>
</tr>
<tr>
<td>applicationName</td>
<td>1.3.6.1.4.1.[EN].1.3.0</td>
<td>String</td>
<td>Name of the application being executed by Studio.</td>
</tr>
<tr>
<td>applicationRevision</td>
<td>1.3.6.1.4.1.[EN].1.4.0</td>
<td>String</td>
<td>Revision Number of the application being executed by Studio.</td>
</tr>
<tr>
<td>tagTable</td>
<td>1.3.6.1.4.1.[EN].1.5</td>
<td>Table</td>
<td>Table containing a list of the tags used in the current application and exposed to the SNMP Manager.</td>
</tr>
</tbody>
</table>

The Table tagTable has 5 columns with the following information:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>tagName</td>
<td>String. The tag name.</td>
</tr>
<tr>
<td>2</td>
<td>tagType</td>
<td>String. The Tag Type (“bool”, “integer”, “real” or “string”).</td>
</tr>
<tr>
<td>3</td>
<td>tagValue</td>
<td>String. The current tag value.</td>
</tr>
<tr>
<td>4</td>
<td>tagQuality</td>
<td>String. The quality of the tag value. (“good” or “bad”).</td>
</tr>
<tr>
<td>5</td>
<td>tagTrap</td>
<td>String. A number that indicates if the tag fires a trap when its value changes. “1” means trap is active; “0” means trap is inactive.</td>
</tr>
</tbody>
</table>

You must configure the tags that will be exposed by the Studio SNMP Agent (by default, no tags are exposed). In order to configure the tags that will be exposed by the Studio SNMP Agent, just create a Text File with the CSV (Comma Separated Value) format. The file name must be SNMP.csv and it must be saved in the \\Config sub-folder of your application.

You can configure one tag in each line of the file, according to the following syntax:

TagName, Trap

Where:
- **TagName**: Name of the tag that will be exposed by the Studio SNMP Agent.
- **Trap**: Flag indicating if the Studio SNMP Agent must generate traps when this tag changes of value (0=trap disabled; 1=trap enabled).

The following example illustrates a valid SNMP.CSV file, which makes three tags available to remote SNMP Manager (TagLevel, Alarm and Second) and generates traps automatically when the tag Alarm changes of value.

TagLevel, 0
Alarm, 1
Second, 0
## Map of Revision

<table>
<thead>
<tr>
<th>Revision</th>
<th>Author</th>
<th>Date</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Fabio Terezinho</td>
<td>November 7, 2006</td>
<td>Initial Revision</td>
</tr>
</tbody>
</table>