English (United States)
Call us! 512-349-0334 or (877) INDUSOFT

InduSoft Web Studio Forums

Find additional forum posts in in the Forum Archives. For assistance view the Forum Frequently Asked Questions.

[SOLVED] Gateway doesn't start automatically (but it used to) [InduSoft Web Studio]
Last Post 11 Mar 2019 11:11 AM by Adler. 2 Replies.
Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages Resolved
AdlerUser is Offline
New Member
New Member
Posts:3


--
11 Mar 2019 08:17 AM
    Hello everyone.
    Before I ask the question I am here for, I just wanna say its going to be hard to determine if the problem is within our laptops OR the software itself.

    I have a problem with automatically launching the Gateway application (StADOSvr.exe).

    What am I doing:
    I am creating a completely new project --> Set the default database to read the localhost database with this connection string:
    Provider=MYSQLCLIENT; Server=127.0.0.1; Database=dblazur; Uid=root; Pwd=toor; Port=3306;
    (the port in the Advanced settings is set to 3997)
    In the "Tasks" tab in "Project Explorer" (on the left), at the Database/ERP Connections, I've inserted the same connection string, username and password.
    And then when I click on Play, the screen launches normally, BUT I cannot see the StADOSvr.exe in the Taskbar or in Task Manager.


    What I've tried:
    - Launching StADOSvr.exe and after that "Play" the project - Yes, the StADOSvr.exe application works and I can see it in the taskbar, but I don't see the connection to the database inside it (it doesn't connect to the localhost database)
    - Allowing 3306 and 3997 ports through the firewall (yes, both inbound and outbound connections) - No result.
    - Activating the administrator account on my PC, logging in with it, launching the InduSoft software, creating a new project, lauching it - No change, the StADOSvr.exe doesn't start up automatically.
    - Giving all permissions to all users on my PC and ticking off the "Read-Only" mark in Properties - No result.


    Things to keep in mind:
    - I have tried to install the software on a clean Windows 10 Pro and that gateway StADOSvr.exe application didn't run again.
    - I have full control over my PC.
    - I've allowed my PC to run applications from unknown publishers.
    - I am sure I don't have any viruses.
    - The InduSoft version, that I am using is v8.1
    - In the "Tasks", the only things that are set to Automatically are:
    *Background Task
    *Core runtime
    *Viewer
    Note: I tried setting "Driver Runtime" to automatic, but an error/warning popped out stating "Need to pass a command line parameter with the name of the driver"

    What versions am I using:
    IWS version: 8.1
    Service Pack: 1

    Very strange:
    - Whenever I open a old project (made in the exact same version (v8.1)), the StADOSvr.exe application RUNS and shows the localhost database perfectly. I've tried comparing their .app files and see the differences between them but it was nothing more than just some screens.

    I am really really looking forward to fix this issue, because it seems small, but its really important.
    Thanks in advance!
    Adler :)
    AdlerUser is Offline
    New Member
    New Member
    Posts:3


    --
    11 Mar 2019 11:09 AM
    SOLVED
    Ok, so just to wrap this up, i contacted a guy (Esteban) from the Live chat at the InduSoft homepage and he solved my issues in less than 10 minutes.

    There wasn't really a problem. The Gateway (StADOSvr.exe) will not run automatically, unless you give him a reason to (give him command to run).
    Basically what he did was:
    1.He added a new trend to check from the database.
    2.From the Tasks he set "TCP/IP Server Runtime" to automatic.
    3.Saved the project.
    4.Played the project and everything was running smoothly.

    As far as the "Driver Runtime" being set to automatic (from the Tasks again),with the error/warning popping out stating "Need to pass a command line parameter with the name of the driver" - He just added a PLC driver to the project and the error was gone.
    AdlerUser is Offline
    New Member
    New Member
    Posts:3


    --
    11 Mar 2019 11:11 AM
    Thank you very much Esteban! When i closed the chat, I didn't really see anywhere I could've rate the help you gave me, but if you see this message - Esteban, you the real MVP.
    You are not authorized to post a reply.