
Other brand or product names are trademarks or registered trademarks of their respective owners.

Copyright © 2005 - 2007 InduSoft, Ltd. All rights reserved worldwide. This document shall not be reproduced or copied in any manner without expressed written authorization from InduSoft.

The information contained within this document is subject to change without notice. InduSoft, Ltd. does not guarantee the accuracy of the information.

PN: IND-GSG-WD001
Contents

CHAPTER 1. WELCOME TO INDUSOFT WEB STUDIO ................................................................. 1
  OVERVIEW ......................................................................................................................... 2
  ABOUT InduSoft WEB STUDIO ....................................................................................... 3
    Main Features ......................................................................................................................... 3
    System Requirements .............................................................................................................. 5

CHAPTER 2. ABOUT THIS PUBLICATION ........................................................................... 7
  Text Conventions .................................................................................................................... 8
  Mouse and Selection Conventions .......................................................................................... 9
  Windows Conventions ............................................................................................................ 10
  Related Publications .............................................................................................................. 11

CHAPTER 3. INSTALLING THE SOFTWARE ...................................................................... 13
  Installing InduSoft WEB STUDIO ...................................................................................... 14
  Starting InduSoft WEB STUDIO .......................................................................................... 16
  Installing CEView Software ................................................................................................. 17
  Uninstalling InduSoft WEB STUDIO .................................................................................. 19

CHAPTER 4. WORKING WITH THE IWS INTERFACE .................................................... 23
  Overview ............................................................................................................................... 24
  Using the Title Bar .................................................................................................................. 26
  Reading the Status Bar .............................................................................................................. 27
  Using the Menu Bar ................................................................................................................ 28
  Using the Toolbars ................................................................................................................ 29
  Using the Workspace ............................................................................................................. 32

CHAPTER 5. WORKING WITH TAGS ................................................................................ 35
  Naming Tags and Tag Fields ................................................................................................. 36
    Tag Syntax ............................................................................................................................ 36
    Tag Field Syntax .................................................................................................................. 37
  Working with Tag Folders ...................................................................................................... 41
  Understanding the Tag Types ............................................................................................... 42
  Using Array Tags .................................................................................................................... 43
  Using Indirect Tags ................................................................................................................ 45
  Resetting Tags Database ....................................................................................................... 46

CHAPTER 6. CREATING AN IWS APPLICATION ........................................................... 47
  Creating a New Application ................................................................................................. 48
  Specifying Project Settings .................................................................................................. 50
  Creating Tags ........................................................................................................................ 52
  Creating the Start-up Screen (MAIN.SCR) .......................................................................... 54
CREATING THE SYNOPTIC SCREEN (SYNOPTIC.SCR) ................................................................. 59
  Creating a Screen Title ........................................................................................................ 59
  Creating Date/Time Text Objects ......................................................................................... 60
  Creating an Exit Icon ........................................................................................................... 62
  Testing the Application ......................................................................................................... 63
  Creating a Tank Object ......................................................................................................... 67
  Selecting a Tank .................................................................................................................... 69
  Testing the Application ......................................................................................................... 71
  CONFIGURING THE I/O COMMUNICATION DRIVER ............................................................. 72

CHAPTER 7. RUNNING THE WEB-BASED APPLICATION .......................................................... 81

CHAPTER 8. RUNNING FROM A REMOTE STATION .............................................................. 85
Chapter 1. Welcome to *InduSoft Web Studio*

InduSoft Web Studio™ (or IWS) is a powerful, integrated tool that exploits key features of Microsoft® operating systems, and enables you to build full-featured SCADA (Supervisory Control and Data Acquisition) or HMI (Human-Machine Interface) applications for your industrial automation business.
Overview

This *InduSoft Web Studio Getting Started Guide* is intended for individuals using IWS for the first time. This publication will help you quickly familiarize yourself with the basic functions of IWS.

**Note:**
InduSoft assumes you are familiar with Microsoft Windows®. However, if you need assistance as you work, we suggest using the Help feature on the Windows desktop **Start** menu.

This guide is divided into the following chapters:

- **This chapter** provides a brief overview of the IWS product, including its main features and system requirements.
- **Chapter 2, About This Publication**: Provides information about this guide, such as conventions used. It also directs you to related InduSoft publications.
- **Chapter 3, Installing the Software**: Explains how to install IWS and CEView on your system.
- **Chapter 4, Working with the IWS Interface**: Describes all the elements of the IWS development environment; including menu bars, toolbars, dialog boxes, buttons, menus, and so forth.
- **Chapter 5, Working with Tags**: Describes the procedures for creating and editing tags for the tags database; including a description of the proper syntax, and tag types.
- **Chapter 6, Creating an IWS Application**: Explains how to create and edit applications, objects, screens, and drivers. Also explains the procedure for testing your applications.
- **Chapter 7, Running the Web-Based Application**: Explains how to start and run your Web-based applications.
- **Chapter 8, Running Applications from a Remote Station**: Explains how to run and manage applications remotely.
About InduSoft Web Studio

IWS applications consist of animated operator-interface screens, communication drivers (for PLCs and I/O protocols such as Modbus, DFS, Profibus, and so forth), tags database, and additional modules such as alarm monitors, logic, trend control charts, recipes, schedulers, and security system.

IWS applications interface with industrial I/O systems and other Windows applications in the run-time environment using ODBC, DDE, NetDDE, OPC, or TCP/IP protocols. You can also operate the application through a standard Web browser (Internet Explorer or Netscape).

The product consists of two parts:

- The development system software, which runs on a desktop, laptop, or industrial PC running any operating system currently supported by Microsoft, except Windows CE; and
- The run-time system software, which runs on any operator interface workstation running any operating system currently supported by Microsoft, including Windows CE.

Note:
The run-time system software for the Windows CE operating system (CEView) is usually pre-loaded on the HMI. If necessary, you can update the CEView version of the development system software by downloading the current version to the HMI or PDA.

You can run IWS applications on your development workstation or download it to a run-time station (through a serial or TCP/IP connection) and run the application using the IWS or CEView run-time software. The workstation processes scan data from connected devices according to parameters defined in the application and then react to, display, store, and upload the data.

Main Features

The IWS product offers the following features and functions:

- Web interface that allows you to visualize screens in a Web browser (thin client) through the Internet/intranet and exchange data with the server by TCP/IP protocol;
- Platform-independent application that allows you to run applications built with IWS to run under any operating system currently supported by Microsoft;
- Online, remote application management and configuration (download/upload, commands, system and network diagnostics, and debugging);
- An integrated, Windows XP-like development environment with toolbars, dialogs, menus, and customizable toolbars;
- A user-friendly screen editor that enables you to build application screens on the fly at runtime;
- A library of more than 100 symbols and dynamic objects, such as:
  - Frames
  - Icons
  - Motors
  - Pipes
  - Meters and gauges
  - LED-style indicators
  - Text and numeric displays
  - Common controls
  - Sliders and switches
  - Pumps and valves
  - Pushbuttons
  - Vehicles
- Cross-reference tool to locate tags throughout the project;
- Active-X object containers;
- Full-featured objects and dynamics with customizable object properties such as bar graphs, color, resizing, position, rotation, hide/unhide, commands, hyperlinks, and text input/output;
- An open architecture API that exchanges tag values with external software products and is Microsoft.NET architecture-compliant;
- Merges modular worksheets and screens into other applications easily;
- Screen and object password-protected run-time security (256 levels);
- OPC Client and Server modules with an integrated OPC Browser, DDE Client and Server modules, and TCP/IP Client and Server modules (that exchange tag values and configure redundancy systems);
- More than 200 communication drivers for different devices (such as PLCs) from manufacturers such as Allen-Bradley, Siemens, GE-Fanuc, as well as standard protocols such as MODBUS RTU/ASCII, DeviceNet, Profibus, Interbus, and more;
- Logical expressions and scripting language with more than 200 functions;
- Online/historical alarms; trends derived from any source, which you can compare to control data; and recipe/report builders (text, XML, or RTF format–ASCII or UNICODE);
- Event scheduler (based on date, time, or tag conditions);
- Translation editor to translate applications into different languages, using one or more CSV files to translate automatically, and switching between languages during run-time;
- Database Spy window (local and remote) to monitor/force tag values and execute functions;
- LogWin module (local and remote) to record DDE, OPC, and TCP/IP transactions, activate modules, trace tags, and so forth;
- A powerful and flexible tag database with Boolean, Integer, Real, and String tags, array tags, classes, and indirect tag-pointers;
- Integrates fully with PC-based control packages (imports tags database) such as ASAP, ISaGRAF, SteepleChase, and Think&Do;
- Dial-up functions to trigger, monitor, and hang up dial-up connections with remote station RAS Servers;
- Functions to send email automatically from IWS (or CEView);
- Connectivity to any SQL Relational Database through ADO providers, even from WindowsCE-based devices;
- VBScript interface fully integrated in the product, supporting all platforms, including the Web Thin Client stations;
- Customizable library of Linked Symbols that can be replicated in several applications; and
- Interface to generate histories (Alarm, Events and Trend) either in the proprietary binary format or to SQL Relational Databases, such as SQL Server, Oracle, and so forth.

⚠️ **Note:**

IWS provides different product types (for example Local Interface and Control Room) for each level of application responsibility. However, IWS does not support some features in certain product types (such as CEView).

---

**System Requirements**

To develop and run applications with IWS, you must install the following hardware and software:

- IBM-compatible computer with an Intel® Pentium IV-compatible processor or higher;
- A desktop operating system that is currently supported by Microsoft;
- Minimum of 256MB random-access memory (RAM); 512GB or higher recommended;
- MS Internet Explorer 6.0 or higher;
- Minimum of 500MB free hard disk space to install the product and the application (the history files/databases will demand additional disk space);
- Ethernet adapter;
- 100% IBM-compatible VGA or SVGA display adapter with 64MB Video RAM (VRAM) or higher;
- Microsoft-compatible pointing device (such as a mouse, trackball or touch-screen);
- Standard keyboard with function keys F1 through F12;
- CD-ROM drive (optional);
- 3.5-inch floppy drive;
- Parallel printer port (optional);
- USB port (optional); and
- Serial COM ports and adapters (optional).

Notes:
- The requirements described above are based on typical applications. Depending on your specific application, the minimum requirements may vary.
- Applications developed with IWS can run under devices powered with the Windows CE operating system (Windows CE v3.0 or Windows CE .NET) such as industrial HMIs or PDAs (PocketPC). Consult your vendor for the hardware requirements when running your application under the Windows CE operating system.
- In addition to the operating systems described above, the Web Thin Client station can be running the Windows 98 or Windows ME operating systems.
- When using a Hardkey instead of a Softkey to license the product, either the parallel or the USB port must be available in the local computer.
- Some of the items listed above as optional may be mandatory depending on your application. For instance, if you need to exchange data with a PLC via a serial interface, the computer must provide a serial COM port.
Chapter 2. About This Publication

This chapter provides the following information about this InduSoft Web Studio Getting Started Guide and other InduSoft publications:

- **Text Conventions**: Describes the text-formatting conventions used in this publication to help you read and assimilate information quickly.
- **Mouse and Selection Conventions**: Describes the conventions used in this publication for using a mouse and selecting objects in a Windows environment.
- **Windows Conventions**: Describes conventions used in this publication for working in a Windows environment.
- **Related Publications**: Lists other InduSoft publications (available on the IWS installation CD-ROM) you can read for more information about the IWS product.
Text Conventions

This publication uses special formatting to help you quickly identify certain items, as follows:

- Titles, labels, and new terms are indicated using italic text.
- File names, messages, and screen text are indicated using bold, monospaced text (for example, D:\Setup.exe).
- Variables and information you must provide are indicated using bold, italicized monospaced text enclosed in < and > brackets (for example, Run the <driver name>.exe file indicates you must provide a driver name.)
- Buttons, menu options, and keyboard keys are indicated in bold.
- Some information is featured in Tip, Note, and Caution boxes as follows:
  - Tips provide useful information that will save development time and improve application performance.
  - Notes provide supplemental information related to the preceding text.
  - Cautions provide information necessary to prevent damage or problems when running the application.
Mouse and Selection Conventions

Because most PCs used for application development run a version of Windows with a mouse, this publication assumes you are using a mouse. This publication also assumes that your mouse is configured so that the left button is the primary button and the right button is the secondary button.

The following mouse and selection conventions are used throughout the Getting Started Guide:

- **Double-click** means to quickly click twice on an object with the left mouse button.
- **Right-click** means to click once on an object with the right mouse button.
- **Click** and **Select** both mean to click once on an object with the left mouse button. In general, you click on buttons and select from lists.
- **Select** also means to use your pointing device to highlight or specify an item on the computer screen. Selecting an object with a touch-screen is usually the same as selecting with a mouse, except that you use your finger to touch (select) a screen object or section.
- You can also use keys on your keyboard to select objects/options. For example, you can use the **Tab** key to move between options, the **Enter** key to open menus, and the **Ctrl** or **Alt** keys in combination with a letter key (for example, **Ctrl+S**) to select a menu option that opens with such a combination key.
- **Drag** means using your mouse/cursor to move an object to a new location on your computer screen. Position your cursor over the object and press the mouse button. As you move the mouse, you move the object. (Usually an outline of the object will move along with the cursor.) When you have the object positioned where you want it, release the mouse button.
Windows Conventions

This publication uses the following Windows conventions:

- **Dialog boxes** (or *dialogs*) are windows that allow you to enter information.
- **Text boxes** (or *fields*) are areas in dialogs where you can type in text.
- **Radio buttons** are white circles in which a black dot (●) appears or disappears when you click on the button. Typically, the black dot indicates that the option or function is enabled (*active*). The absence of a black dot indicates the option or function is disabled (*inactive*).
- **Check boxes** are white squares in which a check (✓) appears or disappears when you click on it with the cursor. Typically, the check indicates that the option or function is enabled (*active*). The absence of a check indicates the option or function is disabled (*inactive*).
- **Buttons** are icons in boxes that appear “pressed” when you click on them.
- **Lists** are panes (white boxes) in windows or dialog boxes containing two or more selectable options.
- **Combo boxes** have arrows that, when clicked, show part or all of an otherwise concealed list.

![Using a Combo Box](image)

- **Interface** or **Development Environment** refers to the entire IWS window.
- **Dockable windows** are windows that you can drag to an edge of the interface and merge with that edge.
- **Toolbars** are dockable windows that contain only buttons and text boxes.

**Note:**
The dialog boxes and procedures described in this publication are valid for Windows XP. Some terms may vary according to the operating system (type, language and version) you are using.
Related Publications

You may want to review the following publications for additional information about IWS:


- **InduSoft Web Studio Product Types:** This document is a comparative table listing all product versions.

- **FAQ for InduSoft Web Studio:** This document answers frequently asked questions about IWS.

- **VBScript Reference Manual:** This document provides a complete programmer’s reference for the Visual Basic Script Language (VBScript). Support for VBScript is built into IWS.

- **User Guide for PanelBuilder Import Wizard (Evaluation):** Included in the Add-Ons folder, this document describes how to use the Import tool to import PanelBuilder applications to IWS.

анс Not:

These publications are located in the Documentation folder on the InduSoft Web Studio CD-ROM. IWS installs the Driver User Guides in the DRV subdirectory of the InduSoft Web Studio folder. Technical information also is available from the Help menu on the IWS menu bar.
Chapter 3. Installing the Software

This chapter provides instructions for installing, starting, and uninstalling IWS and CEView. The information is organized as follows:

- **Installing InduSoft Web Studio**: Explains how to install IWS on your computer.
- **Starting InduSoft Web Studio**: Explains how to run IWS.
- **Installing CEView Software**: Explains how to install CEView on your computer.
- **Uninstalling InduSoft Web Studio**: Explains how to uninstall IWS and CEView.
Installing InduSoft Web Studio

IWS provides development tools for all InduSoft applications, and it runs on all desktop operating systems currently supported by Microsoft.

You can install IWS from the installation CD-ROM, or you can download the installation files from the InduSoft Web site at [http://www.InduSoft.com](http://www.InduSoft.com). For Windows CE applications, you use IWS to download CEView (run-time software) to the Windows CE HMI using a serial or TCP/IP link.

The IWS installation program automatically creates necessary directories, copies files to your hard drive, and creates the IWS icons in your desktop folder.

<table>
<thead>
<tr>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• You must have Administrator privileges on a workstation in order to install IWS.</td>
</tr>
<tr>
<td>• You must uninstall all previous versions of IWS or install the newer version in a different directory. Also, you cannot install the same version of IWS in two different paths of the same computer.</td>
</tr>
</tbody>
</table>

Use the following procedure to install IWS from the CD-ROM:

1. Turn on the power to your development computer and make sure that no other programs are running.

2. Insert the installation CD-ROM into the CD-ROM driver.

<table>
<thead>
<tr>
<th>Notes:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A CD browser window should display automatically. If not, you can start the program manually from Windows Explorer. Navigate to the D:\Installation directory (where D is your CD-ROM drive), and run the Setup.exe file.</td>
</tr>
</tbody>
</table>

3. Double-click on the Installation folder, and then double-click on the InduSoft Web Studio icon to launch the InstallShield® Wizard.

4. Follow the instructions provided by the InstallShield Wizard to proceed with the installation.
5. When prompted to restart Windows, click the **Yes, I want to restart my computer now** radio button, then click **OK**.

**Notes:**
Refer to the *Licensing Your Product* section of the *User Guide* manual (available on your IWS CD-ROM) for instructions about licensing IWS and/or CEView.
Starting InduSoft Web Studio

To run IWS, double-click the shortcut on the desktop or select **Start → Programs → InduSoft Web Studio → InduSoft Web Studio.**

From the Desktop

Starting InduSoft Web Studio

**Tip:**
You can run the IWS development environment under any video setting; however, InduSoft recommends using a resolution of 800x600 (or higher) with more than 256 colors for a more pleasing environment. Application resolution (screen size) is independent of the operating system resolution.
Installing CEView Software

When you install IWS under Windows, the CEView runtime files are stored in the following folder:

\InduSoft Web Studio Folder\Redist\WinCE version\Processor Type\n
Where:

- <InduSoft Web Studio Folder> is the installation directory chosen during installation (C:\Program Files\InduSoft Web Studio is the default installation directory).
- <Processor Type> is the processor platform. InduSoft provides a CEView runtime for all processor platforms supported by the WinCE operating system (Arm, MIPS, MipsFP, Pocket-Arm, Pocket-Mips, Pocket-SH3, PPC, SH3, SH4, Thumb and x86).
- <WinCE version> is the Windows CE version (for example, “CEView” for Windows CE v3.0, “CEView” for Windows CE v4.x, etc.).

To install CEView, use the following steps:

1. Power-on the WinCE device, and the Remote Agent dialog should launch automatically. If it does not, copy the CESERVER.EXE file from the \InduSoft Web Studio Folder\Redist\WinCE version\Processor Type\BIN directory of the Windows computer where you installed IWS.

2. Paste the file into the <non-volatile> folder of your WinCE device and run it.

⚠️ Note:

There are different ways to copy a file into a WinCE device (for example, you can map a shared folder from the Windows computer in the WinCE device or using ActiveSync). If you need assistance copying this file into the WinCE device, contact InduSoft technical support or the hardware manufacturer.

After executing the CESERVER.EXE file, the Remote Agent dialog launches in the WinCE device.

3. Click the Setup button in the Remote Agent dialog and configure the link (serial or TCP/IP) to connect the WinCE device to the Windows computer.
Note:  For better performance, InduSoft recommends using a TCP/IP link between the WinCE device and the Windows computer to download and upload files.

4. Start IWS on the Windows computer.

5. Select **Project → Execution Environment** from the main menu bar.

6. When the **Execution Environment** dialog displays (see following figure), select a connection type (**Network IP**, **Serial Port**, or **Microsoft ActiveSync**) and configure its settings (for example, **COM Port** or **IP Address**).

![Execution Environment Dialog Box](image)

7. Click the **Connect** button to connect IWS to the WinCE device.

8. Click the **Install System Files** button from the **Execution Environment** window (**Target** tab) to download the CEView files to the WinCE device.
Uninstalling InduSoft Web Studio

If you must remove IWS from your system, follow these instructions:

**Caution:**
Before uninstalling IWS, be sure to back up any files you might need later into the ...\My Documents\InduSoft Web Studio v6.1 Projects\ folder. Also, be sure you have the current (or newest) version of the IWS installation CD-ROM or diskettes so you can re-install the software.

*You will lose the product softkey license when you uninstall IWS.*

1. From the Windows taskbar, select Start → Settings → Control Panel (Start → Control Panel) or to open the Control Panel.

   ![Opening the Control Panel](control_panel_image)

2. Double-click on the Add/Remove Programs icon in the Control Panel window.

   ![Add or Remove Programs](add_remove_programs_image)
3. When the *Add or Remove Programs Properties* dialog displays (see figure), select *InduSoft Web Studio* from the list and click *Remove*.

![Add or Remove Programs dialog]

**Selecting the Application for Removal**

The *Install Shield Wizard* will ask you to confirm the removal of the application.

![Indusoft Web Studio removal confirmation]

**Removing the Application**

4. Click *Yes*.

5. When the *Uninstall successfully completed* message displays and the OK button becomes active, click *OK*. Verify that IWS is no longer listed in the *Add/Remove Programs Properties* dialog.

6. Click the *Close Window* button (×) to close the *Add/Remove Programs* dialog, and then close the Control Panel.

7. Open the *Windows Explorer* and browse to the directory containing the *InduSoft Web Studio* directory.

8. Verify that all of the IWS files and folders were deleted. (You can manually delete any that remain.)
Note:
By default, IWS project files are created and saved in your own My Documents folder (C:\Documents and Settings\<user>\My Documents\InduSoft Web Studio v6.1 Projects\) on the hard drive. The uninstall procedure should not delete any files that you have saved here.
Chapter 4. Working with the IWS Interface

This chapter describes the IWS development environment (interface). The information in this chapter is organized as follows:

- **Overview**: Provides a brief description of the tools and interfaces that make up the IWS development environment.
- **Using the Title Bar**: Describes the title bar.
- **Reading the Status Bar**: Describes the status bar.
- **Using the Menu Bar**: Describes the different menu options that you can access from the IWS main menu bar.
- **Using the Toolbars**: Describes the IWS toolbars.
- **Using the Workspace**: Describes the IWS Workspace.
Overview

IWS uses standard, Windows-like tools and interfaces to make the product user-friendly. IWS also provides an integrated, unique development environment (see figure) for easy access to tools and information.
The development environment consists of the following basic areas:

- **Title Bar**: Indicates the active screen or worksheet
- **Menu Bar**: Contains the main product options and controls, which you can easily access using the cursor or your keyboard keys
- **Screens/Worksheets**: Provides the areas where you can edit screens and worksheets
- **Toolbars**: These provide shortcuts to the main commands used in the development environment.
- **Workspace**: Provides tree-view control from which you can access project worksheets and screens
- **Database Spy Window**: Provides a debugging tool, which you can use to monitor and force tags and to execute functions
- **Output Window**: Displays debugging messages

**Note:**

The preceding figure shows the development environment areas and windows in their default positions. You can customize this environment as needed by moving any of the areas into different positions.

You can **right-click** the mouse almost anywhere inside the development environment to display a pop-up menu (similar to the following figure), relating to the context of where you clicked.

![Sample IWS Pop-Up Menu](image_url)
Using the Title Bar

The title bar (located along the top of the IWS window) displays the InduSoft Web Studio icon, the product name, and the name of the active, open screen or worksheet (if any).

![Typical IWS Title Bar](image)

The title bar also contains the following three buttons (from left to right):

- **Minimize** button (罼): Click this button to minimize the IWS window.
- **Resize/Maximize** button (± / ⏎): Click the button to toggle between the two options,
  - **Resize** tiles the IWS window
  - **Maximize** maximizes the IWS window to fill your computer screen
- **Exit** (or **Close**) button (🗑): Click this button to automatically save the database then close IWS. If you modified any screens or worksheets, IWS prompts you to save your work. This button function is similar to the **Exit** command on the **File** menu.

⚠️ **Note:**

Closing the development environment does not close the IWS runtime tasks. To close your run-time tasks, click the **Stop** icon (statusCode) on the **Execution** toolbar or select **Project → Stop Application** from the main menu bar.
Reading the Status Bar

The status bar (located along the bottom of the IWS window) contains fields that identify toolbar buttons and provide information about the active screen.

The fields are as follows (from left to right):

- **Hint** field: Provides a short description of any toolbar button or display object touched by the cursor.
- **License** field: Indicates the license under which IWS is currently running. (The license can be entered or modified using the Register utility located in the program directory.)
- **Caps Lock** field: Indicates whether the keyboard Caps Lock key is on (CAP) or off (empty).
- **Num Lock** field: Indicates whether the keyboard Num Lock key is on (NUM) or off (empty).
- **Scroll Lock** field: Indicates whether the keyboard Scroll Lock key is on (SCRL) or off (empty).
- **ID** field: Displays the ID number of a selected screen object.
- **Screen Coordinate** field: Displays the current location of the cursor (or pointer) on the active screen. When you select a screen object, this field displays the object’s coordinates in the top-left corner. X is the number of pixels from the left edge of the screen and Y is the number of pixels from the top of the screen.
- **Object Size** field: Displays the size (in pixels) of a selected object. W is the width and H is the height of the object.
- **No DRAG** field: Indicates whether dragging is disabled (No DRAG) or enabled (empty) in the active screen.

You might want to disable dragging to change the object properties of an object without moving it from its current location.

Tip:

You can enable/disable dragging by pressing Ctrl+D. Also, you can move objects on the screen, pixel by pixel, by clicking on the object and pressing the arrow keys on the keyboard.
Using the Menu Bar

The menu bar contains the following menus:

```
File  Edit  View  Insert  Project  Tools  Window  Help
```

**Main Menu Bar**

- **File**: Contains options that enable you to create, open, close, save and print application projects and files, and allows you to close the IWS development environment.

- **Edit**: Contains options that enable you to edit your displays and worksheets by cutting, copying, pasting, formatting, and setting security levels. You can also undo edits, make deletions, and search for and replace elements in these displays/worksheets.

- **View**: Contains options that enable you to control the display of the tools and toolbars in the development environment. This menu also provides shortcuts to the dialog boxes you open most frequently, and enables you to customize your toolbars, restore defaults, open the libraries, zoom in and out, and set screen attributes.

- **Insert**: Contains options that enable you to create and configure a variety of application tags, tag classes, documents, drivers, users, security settings, screens and ActiveX objects.

- **Project**: Contains options to execute applications locally and remotely and opens the dialog used to configure general application settings.

- **Tools**: Contains options to open auxiliary tools.

- **Window**: Contains options that enable you to manage open displays and worksheets.

- **Help**: Contains options that link to information about IWS and InduSoft.

**Note:**

- The menu bar is dockable.
- If you right-click on the menu bar, a pop-up menu displays. From this pop-up, you can restore the default location of the menu bar and toolbars.
- You also can use this pop-up to hide toolbars and windows and to customize the development environment.
Using the Toolbars

IWS provides several toolbars containing icons (shortcuts) that enable you to perform different actions within the program. This section describes the function and default location of each toolbar.

Notes:
All toolbars are dockable screen objects. You can move a toolbar to a different screen location by clicking on its title bar and dragging it to a new location.

For more information about the toolbars discussed in this section, see the InduSoft Web Studio Users Guide and Technical Reference Manual.

The following toolbars contain general purpose tools. By default, they are located across the top of the workspace, just below the menu bar:

- **Standard** toolbar: Allows you to perform general actions, such as file management and printing functions.

![Standard Toolbar](image)

**Standard Toolbar**

- **Tag Properties** toolbar: Allows you to create, locate and access different tags and their properties.

![Tag Properties Toolbar](image)

**Tag Properties Toolbar**

- **Execution Control** toolbar: Allows you to execute and manage an application locally or from a remote location.

![Execution Control Toolbar](image)

**Execution Control Toolbar**
- **Web** toolbar: Allows you to open HTML files.

![Web Toolbar]

- **Align and Distribute** toolbar: Allows you to edit screen objects.

![Align and Distribute Toolbar]

The following toolbars contain screen-editing tools. These toolbars are located along the right side of the interface window by default, and they become enabled when you edit graphic screens:

- **Mode** toolbar: Allows you to edit your screens.

![Mode Toolbar]

- **Bitmap** toolbar: Allows you to access the bitmap screen editor tools. (This toolbar is available only when the Background Picture layer is active. You enable the Background Picture layer in the Screen Attributes dialog box.)

![Bitmap Toolbar]

**Note:**

The Bitmap toolbar is hidden by default.

- **Static Objects** toolbar: Allows you to create polygons, rectangles, lines and other objects for your screen.

![Static Objects Toolbar]
□ **Dynamic Properties** toolbar: Allows you to apply dynamics to objects or a group of objects. Dynamics enable you to modify object properties on the fly (during runtime) according to tag values. Some dynamics also enable you to execute commands or insert values (set points) on the tags.

![Dynamic Properties Toolbar](image)

**Dynamic Properties Toolbar**

□ **Active Objects** toolbar: Allows you to create dynamic objects. Active objects typically require more parameters than static objects and provide embedded dynamics.

![Active Objects Toolbar](image)

**Active Objects Toolbar**
Using the Workspace

The IWS Workspace window is a user-friendly interface that enables you to quickly find and/or create any application component (tags, screens, worksheets and so forth). Application components are organized in a tree-view with each one having its own icon and customized description. You can move, resize or hide the Workspace window.

The IWS Workspace

The Workspace window is divided into four tabs, as follows:

- **Database** tab: Provides access to all tags in the application and security system components. This tab includes the following folders:
  - Application Tags
  - Classes
  - Shared Database
  - Internal Tags
  - Security
  - Event Settings
  - Global Procedures

- **Graphics** tab: Provides access to all screens and symbols in the application. This tab includes the following folders and icons:
  - Screens
  - Group Screen
  - Web Pages
  - Symbols
- Graphics Script
- Library
- Layout

**Tasks** tab: Provides access to all task worksheets in the application. This tab includes the following folders:

- Alarms
- Trend
- Recipes
- Reports
- ODBC
- Math
- Script
- Scheduler

**Comm** tab: Provides access to all worksheets configured to establish communication with another device or software. This tab includes the following folders:

- Drivers
- OPC
- TCP/IP
- DDE

**Note:**
You can right-click on all folders and components to display a menu relating to that folder or component.
Chapter 5. Working with Tags

This chapter provides information needed to create and edit tags, including:

- **Naming Tags and Tag Fields**: Explains the required syntax for naming tags and tag fields.
- **Working with Tag Folders**: Explains the purpose of tag folders.
- **Understanding the Tag Types**: Describes the different tag types.
- **Using Array Tags**: Explains how to use array tags.
- **Using Indirect Tags**: Explains how to use indirect tags.
- **Resetting Tags Database**: Explains how to reset the tags database before running the application.
Naming Tags and Tag Fields

This section provides guidelines for naming tags (database location identifiers) and tag fields (a set of parameters inherent in each tag in the database). Applications use tag fields during runtime.

Tag Syntax

You must observe the following syntax guidelines when naming a tag:

- Use letters, numbers and the underscore ( _ ) character.
- Do not use the following characters:
  \ ` ~ ! @ # $ % ^ & * ( ) – = \ + \ [ ] { } < > ?
- Tag names must begin with a letter.
- Maximum tag length is 32 characters.
  Maximum class member length is 16 characters.
- Tag names must be unique—do not specify the same name for two different tags, unless you are creating an array tag and specify a unique index (see Using Array Tags).
- Tag names are not case-sensitive. For readability, however, we recommend using uppercase and lowercase characters; for example, use TankLevel instead of tanklevel.
- Tag names must be different from internal tag names and math functions.

Some valid tag names include:

- Temperature
- pressure1
- count
- x
**Tag Field Syntax**

You can use the Tag Properties dialog (click the Tag Properties icon located on the Tag Properties toolbar) to specify tag field parameters. To access a tag field you must use the following syntax:

```
<TagName>--><TagField>  (for example, second->Max)
```

You can access the following tag fields during runtime:

<table>
<thead>
<tr>
<th>Tag Field Name</th>
<th>Description of Value Associated with Each Field</th>
<th>Tag Type Associated with Field</th>
<th>R=Read Only</th>
<th>RW=Read+Write</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Description of tag configured in Tags database.</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Min</td>
<td>Minimum value that can be written to the tag at runtime</td>
<td>×</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Max</td>
<td>Maximum value that can be written to the tag at runtime</td>
<td>×</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Quality</td>
<td>Tag quality (192=GOOD; 0=BAD). Updates every time tag receives the result of an expression or a value from a communication task (Driver or OPC). Invalid expressions (such as division by 0) or reading communication errors associated with tag sets quality to BAD.</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Size</td>
<td>Array Size. If the tag is not an array tag, returns the value 0.</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>TimeStamp</td>
<td>Records time and date when a tag changes value.</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Tag Field Name</td>
<td>Description of Value Associated with Each Field</td>
<td>Tag Type Associated with Field</td>
<td>R=Read Only</td>
<td>RW=Read+Write</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------</td>
<td>--------------------------------</td>
<td>------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Unit</td>
<td>Brief description (up to 9 characters) of an engineering unit (such as Kg) for a tag value</td>
<td>✔ ✔ ✔ ✔</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>B0 … B31</td>
<td>Value (0 or 1) of any of the 32 bits (b0, b1, b2, … b31) of an integer tag. (B0: LSB B31: MSB).</td>
<td>✗ ✔ ✔ ✗</td>
<td></td>
<td>RW</td>
</tr>
</tbody>
</table>
| AlrStatus     | Status (integer value) of any currently active alarms associated with a tag. Each bit of the integer value indicates a specific status:  
- Bit 0 (LSB): HiHi Alarm active  
- Bit 1: Hi Alarm active  
- Bit 2: Lo Alarm active  
- Bit 3: LoLo Alarm active  
- Bit 4: Rate Alarm active  
- Bit 5: Deviation+ Alarm active  
- Bit 6: Deviation- Alarm active  
For example:  
- If **Tag->AlrStatus** = 2, “Hi” alarm is active.  
- If **Tag->AlrStatus** = 3, “HiHi” and “Hi” alarms are active simultaneously.  
- If **Tag->AlrStatus** = 0, there are no active alarms  
For Boolean tags, only 1 (bit 1), 4 (bit 2) or 16 (bit 4) values are returned. | ✔ ✔ ✔ ✗                   |            | R              |
<table>
<thead>
<tr>
<th>Tag Field Name</th>
<th>Description of Value Associated with Each Field</th>
<th>Tag Type Associated with Field</th>
<th>R=Read Only</th>
<th>RW=Read+Write</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ack</td>
<td>Specifies whether alarms associated with the tag require acknowledgment. This field has only two possible values: • 0: Alarms do not require acknowledgment • 1: At least one alarm requires acknowledgment</td>
<td>✓  ✓  ✓  ✗</td>
<td>RW</td>
<td></td>
</tr>
<tr>
<td>AlrDisable</td>
<td>Specifies whether alarms associated with a tag will become active. This field has only two possible values: • 0: Enables alarm and when an alarm condition occurs, the alarm becomes active. • 1: Disables alarm so that even if an alarm condition occurs, the alarm will not become active.</td>
<td>✓  ✓  ✓  ✗</td>
<td>RW</td>
<td></td>
</tr>
<tr>
<td>HiHi</td>
<td>• If 0, HiHi alarm is inactive. • If 1, HiHi alarm is active.</td>
<td>✗  ✓  ✓  ✗</td>
<td>R</td>
<td></td>
</tr>
<tr>
<td>Hi</td>
<td>• If 0, Hi alarm is inactive. • If 1, Hi alarm is active.</td>
<td>✓  ✓  ✓  ✗</td>
<td>R</td>
<td></td>
</tr>
<tr>
<td>Lo</td>
<td>• If 0, Lo alarm is inactive. • If 1, the Lo alarm is active.</td>
<td>✓  ✓  ✓  ✗</td>
<td>R</td>
<td></td>
</tr>
<tr>
<td>LoLo</td>
<td>• If 0, LoLo alarm is inactive. • If 1, the LoLo alarm is active.</td>
<td>✗  ✓  ✓  ✗</td>
<td>R</td>
<td></td>
</tr>
<tr>
<td>Rate</td>
<td>• If 0, Rate alarm is inactive. • If 1, the Rate alarm is active.</td>
<td>✓  ✓  ✓  ✗</td>
<td>R</td>
<td></td>
</tr>
<tr>
<td>Devp</td>
<td>• If 0, Dev+ alarm is inactive. • If 1, the Dev+ alarm is active.</td>
<td>✗  ✓  ✓  ✗</td>
<td>R</td>
<td></td>
</tr>
<tr>
<td>Devm</td>
<td>• If 0, Dev- alarm is inactive. • If 1, Dev- alarm is active.</td>
<td>✗  ✓  ✓  ✗</td>
<td>R</td>
<td></td>
</tr>
</tbody>
</table>
### Tag Field Name

<table>
<thead>
<tr>
<th>Tag Field Name</th>
<th>Description of Value Associated with Each Field</th>
<th>Tag Type Associated with Field</th>
<th>R=Read Only</th>
<th>RW=Read+Write</th>
</tr>
</thead>
<tbody>
<tr>
<td>HiHiLimit</td>
<td>Limit value for HiHi alarm.</td>
<td>✗ ✓ ✓ ✗</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>HiLimit</td>
<td>Limit value for Hi alarm.</td>
<td>✗ ✓ ✓ ✗</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>LoLimit</td>
<td>Limit value for Lo alarm.</td>
<td>✗ ✓ ✓ ✗</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>LoLoLimit</td>
<td>Limit value for LoLo alarm.</td>
<td>✗ ✓ ✓ ✗</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>RateLimit</td>
<td>Limit value for Rate alarm.</td>
<td>✗ ✓ ✓ ✗</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>DevSetpoint</td>
<td>Set point value for Deviation alarms.</td>
<td>✗ ✓ ✓ ✗</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>DevpLimit</td>
<td>Limit value for Deviation+ alarm.</td>
<td>✗ ✓ ✓ ✗</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>DevmLimit</td>
<td>Limit value for Deviation- alarm.</td>
<td>✗ ✓ ✓ ✗</td>
<td></td>
<td>RW</td>
</tr>
</tbody>
</table>

**Note:**
If the application tries writing a value outside the range specified in the **Min** and **Max** fields, the Tags Database will not accept the new value and will write a warning message in the **LogWin**. If you configure both **Min** and **Max** properties with the value 0 (zero), any value applied to the tag type can be written to the tag.

**Caution:**
You cannot use tag fields (such as Bit fields) to configure **Alarm** or **Trend** worksheets.
Working with Tag Folders

You can use tags as communication points with field equipment, results of calculations, alarm points, etc. In IWS, all tags are organized into folders on the Database tab according to their origin (application, internal or shared). IWS also provides a folder for compound tags, known as classes.

The following is a description of the different IWS tag folders:

- **Application Tags**: User-defined tags. Some of their uses are:
  - Screens
  - Reading from and writing to field equipment
  - Control
  - Performing mathematical calculations (auxiliary tags)

- **Classes**: Structures that allow for high-level encapsulation in the application database. When you create a class-type tag, the tag contains a whole set of values rather than a single value. You create classes by grouping elements, known as members. The maximum number of members for any class depends on the product specification.

- **Shared Tags**: Tags created in PC-based control software and imported into the IWS environment. You cannot edit shared tags in the IWS environment, but you can modify these tags with PC-based control software, and then re-import the modified tags to update the IWS database. Consequently, you can configure shared tags for any IWS task, just as you can any other tag.

- **Internal Tags**: Tags predefined by IWS. Internal tags have predetermined functions (such as time, date, alarm acknowledgment, storage of the logged-on user name, etc.). You cannot delete or modify these tags, but you can access their values from any IWS task.
Understanding the Tag Types

A tag can be one of the following types:

- **Boolean**: Boolean or digital variable (0 or 1).
- **Integer**: Integer number (positive, negative or zero), equivalent to C-type long integer (4 bytes). For example: 0, 5, -200.
- **Real**: Real number (float) internally stored as a double word, equivalent to C-type double (8 bytes, for example: 2.12, -10.5).
- **String**: Tag of up to 256 characters that can contain letters, numbers or special characters. For example: Recipe product X123, 01/01/90, *** On ***.
- **Class**: User-defined, compound tag.

The preceding icons (and their respective tag types) are located in folders on the *Database* tab.
Using Array Tags

IWS tags can consist of a single value or an array of values.

An array tag is a set of tags that all have the same name, but use unique indexes to differentiate between each tag (a matrix of \( n \) lines and \( l \) column). The maximum array size permitted will depend on the product specification.

You can use the following syntax to access an array tag:

\[
<ArrayTagName>[ArrayIndex]
\]

For example: \( \text{tank}[1], \text{tank}[2], \text{tank}[3], \) and \( \text{tank}[500] \).

**Caution:**

You can specify the maximum index for each array tag in the Size column of any datasheet. Specify size \( n \) to indicate that the array tag has positions from 0 to \( n \).

For example, if the size of \( \text{TagA} \) is 3, the tag positions could be: \( \text{TagA}[0], \text{TagA}[1], \text{TagA}[2], \) and \( \text{TagA}[3] \).

In many cases, using array tags will simplify the configuration task. For example, if you want a display to monitor each tank, you could use array tags to configure a single display containing tags linked to any tank (using the \( \text{tk} \) tag as an index containing the tank number). For example,

\( \text{pressure}[\text{tk}], \text{temperature}[\text{tk}], \) and \( \text{temperature}[\text{tk} + 1] \).

An array index can be a tag, a numeric value, or an expression with the arithmetic operator +.

**Note:**

When referring to an array having an index with the arithmetic operation +, you must use the following syntax:

\[
<ArrayTagName>[<NumValue1> + <NumValue2>]
\]

Where \( \text{<NumValue1>} \) and \( \text{<NumValue2>} \) can be integer tags or numerical constants. For example:

\( \text{temperature}[\text{tk}+2] \) or \( \text{temperature}[\text{tk}+6] \)
Using array tags in an IWS task can save a significant amount of application development time. For example, if you wanted tag points related to the temperature of four tanks, the conventional configuration method is:

- `temperature1` high temperature on tank 1
- `temperature2` high temperature on tank 2
- `temperature3` high temperature on tank 3
- `temperature4` high temperature on tank 4

Using array tags simplifies this task, as follows:

`temperature[j]` high temperature on tank \{j\}

Note:
When you create an \(n\)-position array tag, the system creates \(n+1\) positions [from 0 to \(n\)]. For example: `tag_example` with Array Size=4 has five elements, since `start position=0`, and end position=4.
Using Indirect Tags

IWS supports indirect access to tags in the database. For example, consider a tag X of the string type. This tag can hold the name of any other tag in the database (in other words, this tag can provide a pointer to any other tag type, including the class type). The syntax for an indirect tag is straightforward:

`@<IndirectTagName>`

For example, assume that the X tag holds the TEMP string. Reading and/or writing to @X provides access to the value of the TEMP tag.

⚠️ Note:

Any tag created as a string type is a potential indirect tag (pointer).
Resetting Tags Database

The **Reset Tags Database** command is available in the **Tools** menu. (Tools → Reset Tags Database). Select this command to “reload” the tags database on the local station. This command affects all tags stored in the **Application Tags** folder. This option is useful for resetting the application tags and restoring the values they had when the application was loaded for the first time. When you stop the application but leave the development environment open, the tags are not reset by default when the application is started again. Therefore, you can execute this command to reset them before the application runs again.

When this command is executed, the **Startup Value** configured for each tag (Tags Properties dialog) is written to the respective tag. If you did not configure any **Startup Value** for a numeric tag (Boolean, Integer or Real), the value 0 (zero) is written to the tag. If you did not configure any **Startup Value** for a string tag, the empty value (“”) is written to the tag.

This command is disabled (in gray) if there is at least one runtime task running on the local station. You must close all runtime tasks (Project > Stop application) before this command can be executed.

⚠️ **Note:**
The tags stored in the **Internal Tags** folder and in the **Shared Tags** folder (if any) are not affected by this command.

💡 **Tip:**
If you want to reset the application tags automatically whenever you run the application (Project > Run Application), you can check the option **Reset Tags Database when starting application** on the **Preferences** tab of the **Project Settings** dialog.
Chapter 6. Creating an IWS Application

This chapter explains (using a step-by-step tutorial) how to create a working IWS application and how to install and configure an I/O driver.

- **Creating a New Application**: Explains how to create IWS applications.
- **Specifying Project Settings**: Explains how to specify various settings for your application.
- **Creating Tags**: Explains how to create new tags and add them to the IWS Tags database.
- **Creating the Start-up Screen (main.scr)**: Explains how to create the main start-up screen.
- **Creating the Synoptic Screen (synoptic.scr)**: Explains how to create a synoptic screen for your application.
- **Configuring the I/O Communication Driver**: Explains how to configure an I/O communication driver for your application.
Creating a New Application

Use the following procedure to create a new IWS application:

1. Select File → New from the IWS main menu bar.
2. When the New dialog opens, click on the Project tab.

3. Type the name of your application into the Application name text box (for this example, type GetStart).

IWS automatically creates a new directory of the same name and assigns your application file to that directory (notice the Configuration file text box in the previous figure). To put your application file somewhere other than in the \Projects subfolder of InduSoft Web Studio, click Browse and navigate to the preferred directory location.

4. Select a platform from the Target Platform list (for this example, select CEView Standard), then click OK to proceed.

Note:
You use CEView Lite, CEView Standard or CEView PRO target platforms for Windows CE-compliant run-time applications.
5. When the *Project Wizard* dialog displays, select **Empty Application** from the *Template* list, click the **640 X 480** radio button to specify the application resolution, and then click **OK**.

![Project Wizard dialog](image)

*Specifying an Empty Application with 640X480 Resolution*

The new application file name displays in the *Workspace* window. (For this example, the file name is *Project: GetStart.APP*).

![Workspace window](image)

*GetStart.app in the Workspace*
Specifying Project Settings

You can use tabs on the Project Settings dialog to apply certain parameters to the entire project. For example:

- Use the **Identification** tab to provide information that identifies the project application (such as project description, revision number, Company name, Author’s name, field equipment, and general notes).
- Use the **Options** tab to specify generic settings for the application, such as the Target System, Automatic Translation, Alarm history and Events, Default Database and Shared Tags.
- Use the **Runtime Desktop** tab to enable/disable the run-time desktop parameters.
- Use the **Communication** tab to specify communication parameters relating to the application in general.
- Use the **Web** tab to specify the Web Solution settings, such as the Data Server IP address.
- Use the **Preferences** tab to enable/disable warning messages when using the development environment.
Specify the following settings for your new *GetStart.APP* application:

1. Select **Project → Settings** from the main menu bar.

2. When the **Project Settings** dialog displays (see the following figure), click the **Runtime Desktop** tab and type **main.scr** in the **Startup screen** field or select it from the pop-up menu.

When you execute the application, IWS will open the main screen (or whatever screen you specify) automatically.
Creating Tags

A tag is any variable that holds a value. You can create tags at any time during the development of an application. All tags created in an application are stored in the Application Tags folder located on the Database tab in the Workspace (see the following figure).

![Application Tags Folder](image)

Use the following procedure to create a new tag:

1. Double-click on the Datasheet View icon to open the Application Tags worksheet.

2. When creating a new tag, you must set the following main properties:
   - **Name**: Specify a unique tag name. (All tags must have a unique name.)
   - **Size**: Specify the number of elements for an array tag. (For simple tags, you must specify zero.)
   - **Type**: Specify the data type to be supported by the tag (Boolean, Integer, Real, String or Class).
   - **Description (optional)**: Type a description of the tag for documentation purposes only.
   - **Scope**: Specify the communication behavior of the tag between the Server and the Web Thin Client stations.

   - Specify **Local** if you want the tag to have independent values in the Server and Web Thin Client stations.
   - Specify **Server** if you want the tag to share the same value in the Server and Web Thin Client stations.
3. Use the following parameters to create a tag for the sample application:

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Type</th>
<th>Description</th>
<th>Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level</td>
<td>3</td>
<td>Integer</td>
<td>Level of the tank</td>
<td>Server</td>
</tr>
</tbody>
</table>

Notice that **Array Size = 3** was specified for each tag. Each array element relates to one of the three tanks:

- Level[1] ➔ Level of the Tank #1
- Level[2] ➔ Level of the Tank #2
- Level[3] ➔ Level of the Tank #3

Do not use the 0 element (**Level[0]**) in this example (although it is a valid tag).

**Tip:**

You can sort the data in the *Application Tags* sheet and/or insert/remove additional columns to/from the sheet by right-clicking on it and choosing the applicable option from the pop-up menu.

**Note:**

You will create additional tags as you configure the application.
Creating the Start-up Screen (main.scr)

To create a new screen for your application:

1. In the Workspace window, click the Graphics tab. Right-click the Screens folder.

   ![Right-click the Screens Folder](image)

   IWS stores all screens created for an application in this Screens folder.

2. When the pop-up menu displays, select the Insert option to open the Screen Attributes dialog.

   ![Screen Attributes Dialog Box](image)
3. Use this dialog to set screen properties such as size and type. For this example, click the OK button to accept the default settings.

4. Right-click on the new screen and select **Background color** from the pop-up menu. Select the **gray** color, and click OK to apply that color to the screen.

5. Create a Text object by clicking on the **Text** icon.

6. Click on the screen, and type the following text:

   **Welcome to the InduSoft Sample Application.**

7. Double-click on the Text object to open the **Object Properties** dialog.

   **Welcome to the InduSoft Sample Application**

   ![Welcome to the InduSoft Sample Application](image)

   Click here to open the object properties dialog.

   **Click on the Text Object**

   ![Click on the Text Object](image)

   Use this dialog to set properties for the text object.
Notes:

- Double-clicking on any object opens an Object Properties dialog containing parameters related to that object. The features on the dialog change depending on the item selected from the combo box. The combo box list changes depending on which properties you applied to the object.

- The Object Properties dialog contains a pin button that controls whether this dialog remains open. The button changes state (and function) each time you click on it, as follows:
  - When the pin button is released (it looks like this: 🕏), the focus is passed to the object on the screen as soon as it is selected. It is recommended that this button is kept released when you want to manipulate the objects (Copy, Paste, Cut or Delete). Although the Object Properties window is on the top, the keyboard commands (Ctrl+C, Ctrl+V, Ctrl+X or Del) are sent directly to the objects.
  - When the pin button is pressed (กด), the focus is kept on the Object Properties window, even when you click the objects on the screen. We recommend you keep this button pressed when you want to modify the settings of the objects. You can click an object and type the new property value directly in the Object Properties window (it is not necessary to click on the window to bring focus to it). Also, when the pin button is pressed, the Object Properties window does not automatically close when you click on the screen.
  - You can close the Object Properties dialog by clicking 🕏.

8. Check (enable) the Transparent check box to set the background color of the Text object to transparent.

9. Click the Fonts button to specify font settings (for example: Type=Arial, Size=20, Color=Blue).

10. Click the Button icon 🕏 to create a Button object.

11. Click on the screen, press the mouse button and drag the cursor to define the object size.
12. Double-click on the new Button object to open the *Object Properties* dialog and type the following text into the *Caption* field:

Click here to open the synoptic screen.

![Welcome to the InduSoft Sample Application](image)

*Adding a Caption to the Button*

13. Select the Button object and click on the *Command* icon to apply this dynamic to the object.

14. Double-click on the Button object to reopen the *Object Properties* dialog.

15. Click the *Config...* button

![Object Properties](image)

*Applying the Open(“synoptic”) Command Dynamic*

16. In the *Type* field, select *Open Screen*. 
17. In the **Open Screen** field, type *synoptic.scr*.

![Configuration dialog](image)

**Specifying the Screen to Open**

⚠️ **Note:**

You can specify a screen that you have not actually created yet.

18. Click **OK** to close the *Configuration* dialog, and then click ✗ to close the *Object Properties* dialog.

19. Finally, select **File → Save** from the main menu bar, and save the screen as *main.scr*.

20. To close the **Main** screen, right-click on the screen, and select the **Close** option from the pop-up menu.

When a user clicks on this button during runtime, IWS will open the *Synoptic* screen.
Creating the Synoptic Screen *(synoptic.scr)*

To create a new synoptic screen, use the following steps:

1. Select the *Graphics* tab, then right-click on the *Screens* folder.
2. Select the *Insert* option from the pop-up menu. The *Screen Attributes* dialog will display automatically.
3. Use the parameters on this dialog to set the main properties of the screen (size, type, etc.). For this example, click **OK** to accept the default settings. Open the screen in the screen editor window.
4. Right-click on the screen, and select **Background color**.

![Selecting a Background Color](image)

5. When the *Background Fill* dialog displays, select the gray color, and click **OK** to apply this color to the screen.

*Creating a Screen Title*

To create a screen title *Text* object, use the following steps:

1. Click the *Text* icon 📒, click on the screen, and type: *Synoptic Screen*.
2. Double-click on the Text object to open the *Object Properties* dialog.
3. When the dialog displays, enable the *Transparent* check box to set the Text object’s background color to transparent.
4. Click the *Fonts* button, and modify the font settings (for example: *Type=Arial, Size=20, Color=Blue*).
5. Move the object to the top of the screen.

**Synoptic Screen**

**Finished Screen Title**

**Creating Date/Time Text Objects**

**Note:**
Date and Time are internal tags that hold the current date and current time (respectively) from the local station. The Date and Time tags are available for any application.

To create Date and Time Text objects, use the following steps:

1. Click on the **Text** icon, then click on the screen and type:
   
   **Date**: #######.

2. Double-click on the Text object to open the **Object Properties** dialog.

3. When the dialog opens, enable the **Transparent** check box to set the Text object's background color to transparent.

   ![Object Properties](image)

   **Specifying the “Date” Internal Tag to the Text I/O Object**

4. Select the Text object, and click on the **Text I/O** icon to apply this dynamic to the object.

5. Double-click on the Text object to open the **Object Properties** dialog again.

6. Type **Date** into the **Tag/Expression** field (as shown in the preceding figure) to configure the Text I/O dynamic.
During the runtime, IWS replaces the ####### chars you configured for the Text object with the value of the Date tag.

7. Click on the Text icon to again to create a time Text object.

8. Click on the screen, and type **Time: #######**.

9. Double-click on the Text object to open the *Object Properties* dialog.

10. Enable the **Transparent** check box to set the background color to transparent.

11. Select the Text object, and click on the Text I/O icon to apply this dynamic to the object.

12. Double-click on the Text object to reopen the *Object Properties* dialog, and type **Time** into the *Tag/Expression* field (see figure below) to specify the internal tag for the Text I/O dynamic.

![Object Properties dialog](image)

**Specifying the “Time” Internal Tag to the Text I/O Object**

During runtime, IWS replaces the ####### chars with the **Time** tag value. This figure illustrates how your screen should look after you create the Date and Time text objects.

**Synoptic Screen**

**Date: #######** | **Time: #######**

*Finished Date and Time Objects*
Creating an Exit Icon

To create an Exit button for the screen, use the following steps:

1. Click the Library icon \[\text{Library} \] to open the symbols library.

2. In the Library menu tree, open the System Symbols folder and then open the Buttons sub-folder.

3. In the Buttons sub-folder, select button\_exit. The symbol will be displayed in the symbol viewer to the right of the menu tree.

Selecting the “button\_exit” Symbol

4. Click on the symbol; the mouse cursor will change to show that the symbol is ready to be placed in a screen.

5. Switch back to the screen where you want to place the symbol and click in it. The symbol is placed as a Linked Symbol object.
6. With the object still selected, click on the **Command** icon ▼ to apply this dynamic to the object.

7. Double-click on the object to reopen the **Object Properties** dialog.

8. Type `$Shutdown()` into the Expression field to configure this function for the Command dynamic and apply it to the bitmap.

The following figure illustrates how your screen should look after you create the **Exit** icon (right side of screen). Now, when a user clicks on this icon during runtime, IWS will shut down the application.

### Testing the Application

Use the following procedure to test your application:

1. Click the **Run application** icon ▶ (located on the IWS toolbar) to execute the application.

2. Click the **Exit** icon (open door bitmap) or switch back to the development environment of IWS (Alt+TAB) and click the **Stop application** icon ▼ on the IWS toolbar to close the application.
Creating a Tank Object

To add a Tank object to your screen, use the following steps:

1. Click the Library icon (located on the IWS toolbar) to open the symbols library.

2. In the Library menu tree, open the System Symbols folder and then select the Tanks sub-folder.

3. Click on any tank in the symbol viewer to select it for placement.

4. Switch back to the screen where you want to place the symbol and click in it. The symbol is placed as a Linked Symbol object.

5. Double-click on the object to open its Object Properties dialog.

A tank is a combination of different objects and dynamics from IWS (for example a rectangle, a bar graph, etc.). You can modify the properties of this object by selecting the object or dynamic from the Group of Symbols combo-box. For this example, however, you will modify the tag associated with the tank object.

6. Click on the Replace button to associate a tag with the tank object.
7. When the Replace dialog displays (see following figure), you are going to replace the Current Tag **AnalogValue** (an internal tag used to simulate level) by typing **Level[Index]** in the topmost New Tag field.

![Replace Dialog](image)

**Replace Dialog**

You can use the **[Index]** tag to set the array position of the Level tag, and show the level for any of the three tanks in the same object. For example:

- **Index=1**, the object shows the level of Tank #1 (**Level[1]**)
- **Index=2**, the object shows the level of Tank #2 (**Level[2]**)
- **Index=3**, the object shows the level of Tank #3 (**Level[3]**)

8. Click OK to confirm the tag replacement.
Because you have not previously created an **Index** tag in the Application Tags database, IWS displays the following message:

9. Click **Yes** to create the Index tag from the screen editor. (Note that you do not have to open the Application Tags database again to create tags as you configure the application).

10. You must configure the Index tag **Type** as **Integer**, **Size** as **0**, and **Scope** as **Local**. Because the tag is **Local**, it can have different values for the Server station and the Web Thin Client station at the same time. Consequently, the local user (Server station) can be monitoring the level of one tank (for example, **Index=1 Tank#1**) while the remote user (Web Thin Client station) is monitoring the level of another tank (for example, **Index=2 Tank#2**).
The following figure illustrates how your screen should look after you create the tank object (bottom center).

Screen with New Tank Object

Creating a Level Slider Object

To create a level slider object for your application, use the following steps:

1. Click the Library icon to open the symbols library.

2. In the Library menu tree, open the System Symbols folder and then select the Sliders sub-folder.
3. Click on any slider in the symbol viewer to select it for placement.
4. Switch back to the screen where you want to place the symbol and click in it. The symbol is placed as a Linked Symbol object.
5. Double-click on the object to open its Object Properties dialog box.
   A slider is a group of different objects and dynamics from IWS (rectangle, position, etc.). You can modify the properties of this object by selecting the object or dynamic from the Group of Symbols combo-box. For this example, you will modify the tag associated with the object.
6. Click the Replace button to associate a tag with the object.
7. When the Replace dialog displays, type Level[Index] in the topmost New Tag field, then click OK to confirm the tag replacement.
The following figure illustrates how your screen should look after creating the slider object (bottom right).

**Selecting a Tank**

To select a tank, use the following steps:

1. Click on the Text icon to create a Text object.

2. Click on the screen and type: **Tank**: #.

3. Double-click on the Text object to open the *Object Properties* dialog.

4. Enable the **Transparent** check box to set the background color of the Text object to transparent.

5. Select the Text object, and click on the Text I/O icon to apply this dynamic to the object.
6. Double-click on the Text object to reopen the *Object Properties* dialog. Type **Index** in the *Tag/Expression* field to specify this internal tag for the Text I/O dynamic.

![Object Properties dialog](image)

**Specifying the Index Tag on the ‘Tank’ Text Object**

7. Enable the **Input Enabled** check box to permit entering a new value for the Index tag during runtime.

8. Type **1** in the *Minimum Value* field and **3** in the *Maximum Value* field.

During runtime, IWS will replace the # characters configured in the Text object with the Index tag value.

9. Finally, select **File → Save** from the main menu bar, and save the screen as **synoptic.scr**.

The following figure illustrates how your screen should look when you are finished creating your application.

![Synoptic Screen](image)

**Synoptic Screen**

![Finished Application Screen](image)

**Finished Application Screen**
10. Right-click on the screen, and select **Close** from the pop-up menu to close the main screen.

**Testing the Application**

To test your application, use the following steps:

1. Click on the **Run application** icon ![Run Application Icon](image) to execute the application.

2. Type the tank number (1, 2, or 3) in the **Tank** label, and modify the level of each tank using the slider. Note that you can monitor/set the level of each tank independently.

3. To close the application, do one of the following:
   - Click the **Exit** icon (upper right corner)
   - Switch back to the IWS development environment (Alt+TAB)
   - Click the **Stop application** icon ![Stop Application Icon](image)
Configuring the I/O Communication Driver

The IWS run-time software uses I/O drivers to acquire necessary data values from PLCs and other I/O devices. This section explains how to select, install and configure an I/O driver.

1. In the Workspace, select the Comm tab, and right-click the Drivers folder.
2. When the pop-up menu displays, select the Add/Remove drivers option.

Add/Remove Drivers

The Communication Drivers dialog displays as in the following figure.
3. Select a driver from the *Available drivers* list (for this example, use the MODBU-Modbus Protocol RTU/ASCII driver), then click the *Select* button (or double-click on the driver).

   The program moves the selected driver to the *Selected drivers* list.

4. Click **OK** to close the window and save your changes.

   **Note:**
   To remove a driver from *Selected drivers*, select it and click **Remove**.

5. A boxed plus sign displays beside the *Drivers* folder. Click the plus sign or double-click on *Drivers* (the word or folder) to display the subfolders for any drivers you added. (For this example, a MODBU subfolder displays.)

6. Right-click on the *MODBU* folder, and select *Settings* from the pop-up menu.

   ![Select Settings from the Pop-Up Menu](image)
7. When the *Communication Parameters* dialog displays, configure the settings to match the communication parameters configured for the PLC.

![Communications Parameters Dialog for MODBU Driver]

**Tip:**
Select *Help → Communication Drivers* and *MODBU Driver User Manual* for detailed information about configuring these communication parameters.

8. Right-click the *MODBU* folder again, and select **Insert** from the menu.
A Modbu001.drv dialog displays in the Workspace. Notice that the dialog is divided into two sections:

**MODBU001.DRV**

- **Description:**
  
- **Read Trigger:**
  
- **Enable Read when Idle:**
  
- **Read Completed:**
  
- **Read Status:**
  
- **Write Trigger:**
  
- **Enable Write on Tag Change:**
  
- **Write Completed:**
  
- **Write Status:**
  
- **Station:**
  
- **Header:**
  
- **Tag Name** | **Address** | **Drv** | **Add**
  -

**MODBU001.DRV Header**

- **Header:** A gray header with several fields
- **Body:** The worksheet form

9. In the header section, configure the parameters as follows:

- **Description** text box: Type Example Modbus. (This parameter is for documentation; it does not affect the communication in any way.)

- **Enable Read When Idle** text box (Boolean values, 1 = yes and 0 = no): Type 1 so IWS will continue reading these values from the PLC addresses configured in the body of this driver worksheet.

- **Enable Write on Tag Change** text box (Boolean values, 1 = yes and 0 = no): Type 1 so IWS will write the value from the tags configured in this driver worksheet whenever the tags change value.

- **Station** text box (indicates the I/O device number to be accessed by this driver. Typically, the PLC is specified as Device #1.) Type 1.

- **Header** text box.: Type a reference value from the following table, which provides a list of acceptable register types for the MODBU driver.
Note:
You must use a driver-specific format in the Header text box. The format for a ModBus protocol is:
<reference for the type of register>:<initial offset for the first stored value>.

<table>
<thead>
<tr>
<th>Register Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0X</td>
<td>Coil Status</td>
</tr>
<tr>
<td>1X</td>
<td>Input Status</td>
</tr>
<tr>
<td>3X</td>
<td>Input Register</td>
</tr>
<tr>
<td>4X</td>
<td>Holding Register</td>
</tr>
<tr>
<td>ID</td>
<td>Slave ID Number</td>
</tr>
</tbody>
</table>

For example: 4X:0 signifies a Holding Register with an offset of zero.

Sample Header Section

10. Type the following information into the spreadsheet provided at the body section of the Modbu001.drv window:

- **Tag Name**: Type the I/O tag name.
**Address**: Type the PLC Address offset.

11. Associate the Application Tags with the PLC addresses according to the following table:

<table>
<thead>
<tr>
<th>Application Tag</th>
<th>Driver Worksheet</th>
<th>PLC Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level[1]</td>
<td>4X:0 1</td>
<td>4X:1 (Holding Register 1)</td>
</tr>
<tr>
<td>Level[2]</td>
<td>4X:0 2</td>
<td>4X:2 (Holding Register 2)</td>
</tr>
<tr>
<td>Level[3]</td>
<td>4X:0 3</td>
<td>4X:3 (Holding Register 3)</td>
</tr>
</tbody>
</table>

**MODBU001.DRV**

**Description:**

- Example Module
- Increase priority

**Read Trigger:**

- Enable Read when Idle: 1

**Write Trigger:**

- Enable Write on Tag Change: 1

**Station:**

- Header: 4X:0

<table>
<thead>
<tr>
<th>Tag Name</th>
<th>Address</th>
<th>Div</th>
<th>Add</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Level[1]</td>
<td>1</td>
<td>0.000000</td>
<td>0.000000</td>
</tr>
<tr>
<td>2 Level[2]</td>
<td>2</td>
<td>0.000000</td>
<td>0.000000</td>
</tr>
<tr>
<td>3 Level[3]</td>
<td>3</td>
<td>0.000000</td>
<td>0.000000</td>
</tr>
<tr>
<td>*</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Completed Body Section**
12. Save the communication driver sheet (File → Save). When prompted to choose the driver sheet number, type 1, and click OK to save the MODBU001.DRV driver sheet.

![Save the Driver Sheet](image)

To test the communication driver, use the following steps:

1. Click the Run application icon (on the IWS toolbar) to execute the application.

2. Right-click in the Output window (bottom of IWS development environment), and select Settings from the pop-up menu.

![Select Settings from the Popup Menu](image)
3. Enable the **Field Read Commands**, **Field Write Commands** and **Serial Communication** options on the *Log Settings* dialog (see the following figure), then click **OK**.

![Log Settings Dialog](image)

**Specifying the Log Options**

4. Now you can start the application and monitor the communication messages from the *Output* window.
Chapter 7. Running the Web-Based Application

This chapter explains how to prepare your application to run on the Web.

Note:
IWS stores all application screens in the Screens folder, located on the Graphics tab in the Workspace.

To open your application screen, use the following steps:

1. Expand the Screens folder, and double-click on synoptic.scr.

![Workspace Diagram]

Select synoptic.scr.

2. Select File → Save as HTML to save the screen in HTML format.
3. After this command is executed, the Web files are stored in the `Web` subfolder of the application directory.

4. Select **Project → Settings** from the main menu bar, and select the **Web** tab.
5. You must specify the Server station IP address (for the station on which you are running IWS or CEView) in the **Data Server IP Address** field, during runtime. The Web Thin Client station exchanges on-line data (tag values) with the station specified in this field.

6. After configuring the Web settings, click **OK** to close the **Project Settings** dialog.

7. Close all screens in the screen editor (**Window → Close All**), and then select **Tools → Verify Application** to update the **Web Settings** for the Web pages.

<table>
<thead>
<tr>
<th>Caution:</th>
</tr>
</thead>
<tbody>
<tr>
<td>You must execute <strong>Tools → Verify Application</strong> after changing any settings in the <strong>Project Settings</strong> menu.</td>
</tr>
</tbody>
</table>

To test your Web-based application, use the following steps:

1. Click on the **Run application** icon 🎨 (on the IWS toolbar) to execute the application locally on the Server station.

2. Open an Internet browser (Microsoft Internet Explorer or Netscape) and type the URL address to open the `synoptic.html` screen from the Server station (for example: [http://127.0.0.1/synoptic.html](http://127.0.0.1/synoptic.html)).

3. When the **Log On** dialog displays in the browser (see the following figure), type **guest** in the **User Name** field, then click **OK** to open the `synoptic.html` screen in the browser.

![Log On dialog](image)

Logging On as Guest
Notice that you can modify the level of any tank locally (Server Station), using the Viewer run-time module, or remotely (Web Thin Client), using the browser.

**Synoptic Screen**  

![Synoptic Screen Image]

*Modifying the Tank Level*

**Note:**

A Web Thin Client requires an ActiveX component *(ISSymbol.ocx)* to handle screens on the browser. If you connect the Web Thin Client to the Internet, this component is downloaded and registered automatically.

Otherwise, you must copy the *ISSymbol.cab* from IWS’s *BIN* subfolder and paste it into the *\<OSPath>\System32* directory on the Web Thin Client station. Use the WinZip® utility to unzip *(extract)* the files from *ISSymbol.cab* into the *\<OSPath>\System32* directory and register the *ISSymbol.ocx* using the `regsvr32 ISSymbol.ocx` command.
Chapter 8. Running from a Remote Station

This chapter explains how to run your application from a remote location. After configuring an application and testing it locally (on the development station), you can download it to a remote run-time station that is running IWS on Windows desktop or CEView on Windows CE.

1. From the remote target station, select Start → InduSoft Web Studio → InduSoft Remote Agent to verify that the Remote Agent (CEServer.exe) is running.

2. When the Remote Agent dialog displays, click the Setup button.

   ![Remote Agent Dialog](image)

   **Verifying the Remote Agent**

3. When the Setup dialog displays, click Serial or TCP/IP to specify how the device is connected to the development station.

   ![Setup Dialog](image)

   **Specifying the Device Connection Method**
4. Click OK and leave the Remote Agent running on the remote station.

5. Select Project → Execution Environment from the main menu bar to open the Execution Environment dialog.

6. Specify a link type for the Target Station (Network IP or Serial Port). If you select Network IP, type the remote station IP Address into the text box.

7. Click the Connect button to connect to the remote station.

8. Return to the Execution Environment dialog and select the Application tab. Click Send to Target to download the application to the remote station.

9. After all of the application files are downloaded, click Run to execute the application on the remote target station.

Note: InduSoft recommends using TCP/IP for performance reasons.

Note: If the remote station is a CE device, click the Install system files button to download the CEView runtime files to the remote station.